Printable Version of Topic

Click here to view this topic in its original format

[splatterladder] Board _ [splatterladder] - Support _ Linux 64bit no sound in game

Posted by: Nico'x Nov 22 2016, 09:02 PM

Hello,

I'm using Linux 64bit, just because my ping and FPS is better while I'm playing on Linux, and I have one other problem, tried to search on web, tried to fix, followed so many steps, nothing happend, I tried all, "ask ubuntu" "solutions" , nothing fixed, please help me, I'm not really sure with these codes I have to type
we can use TeamViewer or just PM me I will try to fix, or answer on this theard, Thanks in advence.

Cheers,
Nico bash.gif

Posted by: ETc|Jay Nov 23 2016, 02:00 PM

what linux you are using?

what you tried? Maybe your installation is allready broken.


Posted by: Nico'x Nov 23 2016, 02:11 PM

QUOTE (ETc|Jay @ Nov 23 2016, 02:00 PM) *
what linux you are using?

what you tried? Maybe your installation is allready broken.


I'm using Linux Mint 17.3 ... ET works perfect, my ping is too lover then on Windows and my FPS Is over 100, thats the only problem... sadd.gif

Cheers,
Nico

Posted by: ETc|Jay Nov 23 2016, 08:45 PM

try to set in et sound quality to 44khz ultra high.
restart game.

Posted by: $mart Nov 23 2016, 08:55 PM

You need that for the sound on recent OS https://github.com/nullkey/et-sdl-sound


Posted by: Nico'x Nov 23 2016, 11:37 PM

QUOTE ($mart @ Nov 23 2016, 08:55 PM) *
You need that for the sound on recent OS https://github.com/nullkey/et-sdl-sound


Where do I put that, and do I have to unzip?

Posted by: The Loko Nov 25 2016, 04:14 PM

QUOTE (Nico'x @ Nov 23 2016, 11:37 PM) *
QUOTE ($mart @ Nov 23 2016, 08:55 PM) *
You need that for the sound on recent OS https://github.com/nullkey/et-sdl-sound


Where do I put that, and do I have to unzip?

If you use that, you will need to compile it.
It's easier to download http://http.kernwaffe.de/et/ET-Installer/et-sdl-sound and set it as executable:
CODE
chmod u+x et-sdl-sound

Then you can run the game using ./et-sdl-sound.
If you still have no sound, you can try replacing SDL_AUDIODRIVER="alsa" with SDL_AUDIODRIVER="pulse", if still missing sound you may need to install some libraries.
Anyway, the best method to solve those ET annoyances is installing ETLegacy instead!

Posted by: Nico'x Nov 25 2016, 04:19 PM

QUOTE (The Loko @ Nov 25 2016, 04:14 PM) *
QUOTE (Nico'x @ Nov 23 2016, 11:37 PM) *
QUOTE ($mart @ Nov 23 2016, 08:55 PM) *
You need that for the sound on recent OS https://github.com/nullkey/et-sdl-sound


Where do I put that, and do I have to unzip?

If you use that, you will need to compile it.
It's easier to download http://http.kernwaffe.de/et/ET-Installer/et-sdl-sound and set it as executable:
CODE
chmod u+x et-sdl-sound

Then you can run the game using ./et-sdl-sound.
If you still have no sound, you can try replacing SDL_AUDIODRIVER="alsa" with SDL_AUDIODRIVER="pulse", if still missing sound you may need to install some libraries.
Anyway, the best method to solve those ET annoyances is installing ETLegacy instead!


Thanks man, solved!!! I didnt wanted etlegacy because I cant play on PB servers while using etl.

Cheers,
Nico

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)