IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Gamelauncher hack for linux/firefox
BeaTtheMeaT666
post Feb 9 2006, 08:30 AM
Post #1


Private

Group: Members

Joined: 9-February 06
Member No.: 22342



Hi,

after browsing your serverlist I thought I might be handy to have something for linux people to launch ET from firefox. That's what I did (nothing fancy, but cheap):

CODE

#!/bin/sh

#
# etlaunch.sh launches ET from splatterladder.com
#

ET="/usr/games/bin/et"
SERVER=`echo ${1} | cut -d "/" -f 3`

${ET} +connect ${SERVER}



You may have to adjust ${ET} to fit your ET installation.

Make this script executable:

CODE

chmod 755 etlaunch.sh



Then type "about:config" in firefox as URL, an add 2 new variables by clicking right mouse, selecting "New":

The first one is of type "boolean":
network.protocol-handler.external.et

Value is "true".

The second one is of type "String":
network.protocol-handler.app.et

use the path to etlaunch.sh as value

That's it. Just click on the connect button in the serverlist and et should start.

Cheers,

BeaTtheMeaT
Go to the top of the page
 
+Quote Post
sl.Proddi
post Feb 9 2006, 02:39 PM
Post #2


Group Icon Chief_Software_Architect

Group: Management

Joined: 10-May 04
From: Germany
Member No.: 2



the complete URL-Syntax is:
CODE
<protocol>://[<password>@]<ip:port>[/<protocol>][/option1][/option2][/option3][...]


examples:
CODE
et://12.34.56.78:1234/84
et://password@12.34.56.78:1234
etqw://password@12.34.56.78:1234/10


--------------------

Du hast nur einen Termin im Leben und der ist bereits terminiert !

http://video.google.de/videoplay?docid=5024787479139933029
Go to the top of the page
 
+Quote Post
Thermo
post Feb 9 2006, 05:29 PM
Post #3


Group Icon Sergeant First Class

Group: Members

Joined: 29-November 04
From: Dortmund, Germany
Member No.: 1709



Hey thanks, BeatTheMeat! cheers.gif respect.gif sign_fixed.gif


--------------------
SPEED: FAST MOVEMENT

Go to the top of the page
 
+Quote Post
Kernel
post Feb 27 2006, 02:32 AM
Post #4


Private

Group: Members

Joined: 27-February 06
Member No.: 23306



help.gif Doesn't work for me. It said that et is not a registered protocol.
bash.gif crash.gif
Go to the top of the page
 
+Quote Post
phantom666
post Sep 7 2006, 03:24 PM
Post #5


Private

Group: Members

Joined: 27-August 06
Member No.: 32584



where do i put the first thing on the et console?
Go to the top of the page
 
+Quote Post
durand
post Sep 30 2007, 01:21 PM
Post #6


Private

Group: Members

Joined: 29-September 07
Member No.: 60208



You dont need to use the ET console for anything...
Save that script somewhere, like /home/username/bin. Then open a terminal, cd to the folder, and type chmod a+x scriptname. Then, if you use the Opera web browser, go to Tools > Preferences > Advanced > Programs > Click on add: In protocol, type et and then open in other application, just locate the file.
Now, if you just click on the link at SplatterLadder, it should open ET.
QUOTE
Doesn't work for me. It said that et is not a registered protocol.


That might be because you left a space in the value somewhere or made a slight mistake.
Go to the top of the page
 
+Quote Post
Maitre Bra*tac
post Dec 8 2007, 07:55 PM
Post #7


Private

Group: Members

Joined: 4-September 05
Member No.: 13993




Hello,
I am French and I am under ubuntu, and I do not understand anything at all.

I am sorry but I am a novice under ubuntu, so
There is possible to describe the procedure step by step please. Thanks help.gif help.gif
Go to the top of the page
 
+Quote Post
s0lstiCe
post Jan 25 2008, 04:00 PM
Post #8


Private

Group: Members

Joined: 17-December 07
Member No.: 64261



Hello,
I am French too :)
Sorry, but I have not understood this :
CITATION
You may have to adjust ${ET} to fit your ET installation


Thanks for your answer.

s0lstiCe
Go to the top of the page
 
+Quote Post
Welon
post Feb 12 2008, 12:52 PM
Post #9


Private

Group: Members

Joined: 31-January 08
Member No.: 66712



it means that
QUOTE
ET="/usr/games/bin/et"
might not be the folder you've installed ET in. In that case you have to edit this line.
Go to the top of the page
 
+Quote Post
PisseNisse
post Feb 21 2008, 06:45 PM
Post #10


Private

Group: Members

Joined: 17-December 07
Member No.: 64243



Didn't get it to work with Firefox, must have screwed up somehow, so I tried it on Opera webbrowser and it works like a charm.

In Opera you open "Tools"->"Preferenses"->"Advanced"->"Programs"
Then you choose "Add", type "et" as protocol and browse to your etlaunch.sh

Thanks BeaTtheMeaT for making the script

This post has been edited by PisseNisse: Feb 21 2008, 06:47 PM
Go to the top of the page
 
+Quote Post
s0lstiCe
post Mar 1 2008, 11:40 AM
Post #11


Private

Group: Members

Joined: 17-December 07
Member No.: 64261



CITATION(Welon @ Feb 12 2008, 12:52 PM) *
it means that
CITATION
ET="/usr/games/bin/et"
might not be the folder you've installed ET in. In that case you have to edit this line.



Thanks for the answer,
On my Kubuntu (7.10) address is:
/Home/s0lstiCe/.etwolf/

Good game all
Go to the top of the page
 
+Quote Post
morsik
post May 2 2008, 02:36 PM
Post #12


Private

Group: Members

Joined: 1-May 08
Member No.: 71233



QUOTE (s0lstiCe @ Mar 1 2008, 12:40 PM) *
On my Kubuntu (7.10) address is:
/Home/s0lstiCe/.etwolf/


Here is directory for downloaded files, profiles, mods. Not for Game Binaries. In default (in my) installation, ET installs in /usr/share/games/enemy-territory

Well, you must add:
CODE
ET="/usr/share/games/enemy-territory/et"

(an example for me)

PS. I have Fedora.

This post has been edited by morsik: May 2 2008, 02:36 PM
Go to the top of the page
 
+Quote Post
Nizzle
post May 30 2008, 09:41 PM
Post #13


Private

Group: Members

Joined: 6-June 05
From: Dordrecht..
Member No.: 9343



I might have a little problem here sadd.gif

made the script.. changed the location of my ET directory (tested this thing and it does launch ET for me)
made the changes to firefox and that too seems to do something..

now when I click the et links from splatterladder firefox gives me a selection box of what app to run.. made sense to me since it has an option for remember my decision
it even shows the etlaunch.sh in that dialog

all of that seemed to work properly and made me very happy.. I closed some apps and hit the OK button with remember my decision and etlaunch.sh marked
and now it doesn't do shit.. sadd.gif

sooo.. suggestions please :)
running Ubuntu 8.04 in 64 bit mode which seems to have firefox3


**EDIT**
yay fixed it.. dunno how but it works now =D

This post has been edited by Nizzle: May 30 2008, 10:54 PM


--------------------
Go to the top of the page
 
+Quote Post
DogsOfWar
post Oct 3 2008, 12:45 AM
Post #14


Private

Group: Members

Joined: 3-October 08
Member No.: 76940



QUOTE (Nizzle @ May 31 2008, 04:41 AM) *
I might have a little problem here sadd.gif

made the script.. changed the location of my ET directory (tested this thing and it does launch ET for me)
made the changes to firefox and that too seems to do something..

now when I click the et links from splatterladder firefox gives me a selection box of what app to run.. made sense to me since it has an option for remember my decision
it even shows the etlaunch.sh in that dialog

all of that seemed to work properly and made me very happy.. I closed some apps and hit the OK button with remember my decision and etlaunch.sh marked
and now it doesn't do shit.. sadd.gif

sooo.. suggestions please :)
running Ubuntu 8.04 in 64 bit mode which seems to have firefox3


**EDIT**
yay fixed it.. dunno how but it works now =D

Hi Nizzle, I have the same setup, Ubuntu like the first line to be bash. !/bin/sh also works but just for completeness... If you don't have either as the first line it will fail as you describe.

To get mine to work I also had to change the network.protocol-handler.app.et setting to (ignore quotes) "sh etlaunch.sh"

And the path on my Ubuntu only needed to be et

However the physical path in Ubuntu is usually /usr/local/games/enemy-territory
===================
#!/bin/bash

#
# etlaunch.sh launches ET from splatterladder.com
#

ET="et"
SERVER=`echo ${1} | cut -d "/" -f 3`

${ET} +connect ${SERVER}

This post has been edited by DogsOfWar: Oct 3 2008, 12:56 AM
Go to the top of the page
 
+Quote Post
chef^^
post Jan 9 2009, 05:30 PM
Post #15


Private

Group: Members

Joined: 29-November 07
Member No.: 63350



(BeaTtheMeaT666 @ Feb 9 2006, 09:30 AM) *
Hi,

after browsing your serverlist I thought I might be handy to have something for linux people to launch ET from firefox. That's what I did (nothing fancy, but cheap):

#!/bin/sh

#
# etlaunch.sh launches ET from splatterladder.com
#

ET="/usr/games/bin/et"
SERVER=`echo ${1} | cut -d "/" -f 3`

${ET} +connect ${SERVER}



You may have to adjust ${ET} to fit your ET installation.

Make this script executable:

chmod 755 etlaunch.sh



Then type "about:config" in firefox as URL, an add 2 new variables by clicking right mouse, selecting "New":

The first one is of type "boolean":
network.protocol-handler.external.et

Value is "true".

The second one is of type "String":
network.protocol-handler.app.et

use the path to etlaunch.sh as value

That's it. Just click on the connect button in the serverlist and et should start.

Cheers,

BeaTtheMeaT


Could someone make a video of this to YouTube? Please... Im like the worst linux user ever after 3 days of use grin.gif
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st November 2018 - 09:52 AM