IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> game integrity violation after 2.60b (linux)
[bigmac]
post May 9 2006, 06:22 PM
Post #1


Group Icon Corporal

Group: Members

Joined: 27-January 06
Member No.: 21677



Hey, i get the game integrity violation #20004 after updating to 2.60b. I'm using linux and thought maybe it was a group or owner permission thing, but changing those to include user and root didn't help (or possibly I did it wrong).
But i looked through the backlog on the terminal and saw this: Hacked cvar: cg_tracerwidth. What does that mean? I havent hacked it.

All I did was replace the files et.x86 and etded.x86 with the new ones downloaded from id Softwares page. I'm new to linux so I'm not so savvy with it :)

By the way it was a 2.60b server i hooked up to.

Best regards.
Go to the top of the page
 
+Quote Post
NHLfan
post May 9 2006, 09:39 PM
Post #2


Group Icon General of the Army

Group: Members

Joined: 8-August 04
From: Vienna, AT
Member No.: 366



You (client) shouldn't update, it's atm better if only servers update...

you should also contact Evenbalance/Punkbuster and describe it to them


--------------------
Go to the top of the page
 
+Quote Post
[bigmac]
post May 9 2006, 09:49 PM
Post #3


Group Icon Corporal

Group: Members

Joined: 27-January 06
Member No.: 21677



QUOTE(NHLfan @ May 9 2006, 10:39 PM) [snapback]20348[/snapback]

You (client) shouldn't update, it's atm better if only servers update...

you should also contact Evenbalance/Punkbuster and describe it to them


Yes i reinstalled the game with plain 2.60 and that works. I'm curious to know how many had these symptoms. Besides cg_tracerwidth i got cf_wstats violation as well. None of them are related to aim, sight or movement according to the info i could gather here and there.

I'll try the link there.
Go to the top of the page
 
+Quote Post
#R|E#simple
post May 10 2006, 09:46 AM
Post #4


Group Icon Corporal

Group: Members

Joined: 2-December 05
Member No.: 18707



if i was to upgrade all my servers, and people had NOT upgraded their client...this would mean its a total missmatch and they wouldnt be able to join my seervers ?

so within the next couple of weeks i wouldnt see any kind of popularity on my servers am i right?


--------------------

Go to the top of the page
 
+Quote Post
NHLfan
post May 10 2006, 09:52 AM
Post #5


Group Icon General of the Army

Group: Members

Joined: 8-August 04
From: Vienna, AT
Member No.: 366



ZITAT(#R|E#simple @ May 10 2006, 10:46 AM) [snapback]20360[/snapback]

if i was to upgrade all my servers, and people had NOT upgraded their client...this would mean its a total missmatch and they wouldnt be able to join my seervers ?

afaik - No! It shouldn't make any problems... unless you run etpro on your server

you can also read this topic with some informations and discussions


--------------------
Go to the top of the page
 
+Quote Post
Hellraiserr
post May 10 2006, 11:18 AM
Post #6


Group Icon Master Sergeant

Group: Members

Joined: 4-July 05
From: Netherlands weedheaven
Member No.: 10679



You can just patch all your servers, players wont get any problems. Patched mine this morning and not seeing people having troubles


--------------------
WeedHeaven|No*Xp*Reset
84.244.186.26:27960 50 slots
http://www.weedheaven.com
Go to the top of the page
 
+Quote Post
ASD
post May 10 2006, 09:33 PM
Post #7


Group Icon Staff Sergeant

Group: Members

Joined: 16-January 05
From: Vienna
Member No.: 3226



i had the same problem yesterday

today i tried again
patched client (win) connect to patched server (linux)

and i can play without getting kicked

but i fund this line in my server log...

CODE

ET PB Server: Kicking for new violations has been temporarily disabled per PB Master Servers - use the pb_sv_enablekicks command to manually re-enable kicks.


--------------------
Servers:
QW://qw.auz.at:27733 24mapsXPsave
QW://df.auz.at:27733 DogFight
ET://et.auz.at:27960 XPsave 48H
ET://tj.auz.at:27960 Trickjump 200sec Adrenaline

Go to the top of the page
 
+Quote Post
Hellraiserr
post May 11 2006, 07:36 AM
Post #8


Group Icon Master Sergeant

Group: Members

Joined: 4-July 05
From: Netherlands weedheaven
Member No.: 10679



Yes i see the same lines so many times in my serverlogs.
But what i did noticed was that some of them, keep on connecting in the players list. One was about 5 minutes connecting, i went looking in serverlogs, and he got that violation integrity. But after that directly the message there what you told:
ET PB Server: Kicking for new violations has been temporarily disabled per PB Master Servers - use the pb_sv_enablekicks command to manually re-enable kicks. But he was still on the server connecting so very strange is it and still can give troubles.


--------------------
WeedHeaven|No*Xp*Reset
84.244.186.26:27960 50 slots
http://www.weedheaven.com
Go to the top of the page
 
+Quote Post
Bigun
post May 27 2006, 04:05 AM
Post #9


Private

Group: Members

Joined: 27-May 06
Member No.: 27568



Ok folks, I'm using Linux.. having the same issue. My buddy... running Linux.... same issue.

This seemed to start after we both upgraded to 2.60b. The server we play on is also updated... I've tried a brand new username thinking something had gotten fubared, it didn't help. As far as the cvar messages go, I've seen at least 5 different ones. I've started writting them down. Any clues as to what can fix this?
Go to the top of the page
 
+Quote Post
linuxinit
post May 29 2006, 06:33 AM
Post #10


Private

Group: Members

Joined: 29-May 06
Member No.: 27681



I'm getting this as well on Gentoo. I constantly get a PB message:
CODE
^5PunkBuster Client: Hacked Cvar: cg_tracerwidth


Eventually I get kicked. It doesn't matter what mod. I get it while playing TC:Elite as well. I've contacted EvenBalance but as you all know... They suck and haven't responded.

I refuse to run vulnerable software just to play a game. Not that I even could... Every server that has upgraded would kick for a mismatch anyways...

All I can say is for us to keep emailing EvenBalance and ID until somebody gets the message. This is unacceptable.

(edit)
I might add... I have only been getting kicked in the last 48 hours. Before all I got was the constant bitching from PunkBuster^.

This post has been edited by linuxinit: May 29 2006, 06:34 AM
Go to the top of the page
 
+Quote Post
Bigun
post May 30 2006, 03:50 AM
Post #11


Private

Group: Members

Joined: 27-May 06
Member No.: 27568



QUOTE(linuxinit @ May 29 2006, 06:33 AM) [snapback]21061[/snapback]

I'm getting this as well on Gentoo. I constantly get a PB message:
CODE
^5PunkBuster Client: Hacked Cvar: cg_tracerwidth


Eventually I get kicked. It doesn't matter what mod. I get it while playing TC:Elite as well. I've contacted EvenBalance but as you all know... They suck and haven't responded.

I refuse to run vulnerable software just to play a game. Not that I even could... Every server that has upgraded would kick for a mismatch anyways...

All I can say is for us to keep emailing EvenBalance and ID until somebody gets the message. This is unacceptable.

(edit)
I might add... I have only been getting kicked in the last 48 hours. Before all I got was the constant bitching from PunkBuster^.



Ditto on the constant bitching, but it wasn't just one particular cvar message with me, it's been quite a few different ones.... I've filed a bug with PB as well, post the link to yours, maybe if we bitch enough, something can be done.

http://www.evenbalance.com/troubleticket/u...ae52b77d92d3e49

This post has been edited by Bigun: May 30 2006, 03:51 AM
Go to the top of the page
 
+Quote Post
linuxinit
post May 31 2006, 02:13 AM
Post #12


Private

Group: Members

Joined: 29-May 06
Member No.: 27681



Here's mine:
http://www.evenbalance.com/troubleticket/u...e15c3356c4593b2

I only get that one PB message. If I use the old et.x86 I don't have any problems.

I posted on the Gentoo forums as well:
http://forums.gentoo.org/viewtopic-t-466596-highlight-.html

This post has been edited by linuxinit: May 31 2006, 02:15 AM
Go to the top of the page
 
+Quote Post
phloww
post Oct 21 2006, 10:56 PM
Post #13


Group Icon Private 1st Class

Group: Members

Joined: 19-October 05
Member No.: 16428



although this topic is old i had the same problem. as i think everyone installing a fresh et will encounter this i'll post the howto.
so here is the solution:

download et-2.60.x86.run and install et
download et-260b.zip patch and apply the patch (if you havent already done this)
chmod u+x [et-install-dir]/pb/pbweb.x86
cd to [et-install-dir]/pb/
run pbweb.x86
copy pbweb.x86 to ~/.etwolf/pb/
cd to ~/.etwolf/pb/
run pbweb.x86

thats it. from now on all works fine - no mod will pb-kick cause of violating cvars.

reason for all this: Punkbuster flaw which caused problems punkbuster auto-updating itself. kicks happened because punkbuster is a crappy piece of software and only manual update of pb works.

This post has been edited by phloww: Oct 21 2006, 10:56 PM
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th August 2020 - 11:45 AM