ET: Legacy team is looking for a Mac OS X developer who can help them fixing loading of universal binaries. As Radegast writes on the project's official site:

QUOTE (Radegast)
Right now we have only a very basic support for the Mac OS X platform. ET:L compiles fine, works with etmain and a couple of mods1, but only those mods that aren’t compiled as universal binaries. Mods compiled as universal binaries2 crash upon loading.

Read ticket #74 and contact us on our IRC channel (#etlegacy @ Freenode) or post a message in our forum if you think you can help us fix it.

On a related note, compilation with clang is now possible. Thanks to IR4T4 and /dev/hc’s patch.